Network / / 2024. 6. 26. 11:46

Frame-Relay

 

P2P (Point-to-Point) 방식

 

 

R1)

conf t

int f0/1

ip add 172.16.1.254 255.255.255.0

no shut

int s1/0

no shut

encapsulation frame-relay

# Frame-Relay에는 ietf와 MFR이 있습니다.

# ietf가 기본 값이므로 생략하면 ietf로 설정됩니다.

 

exit

int s1/0.12 point-to-point

# P2P(1:1연결) 형식의 12번 서브 인터페이스에 진입

ip add 172.16.12.1 255.255.255.0

frame-relay interface-dlci 102

 

int s1/0.13 point-to-point

ip add 172.16.13.1 255.255.255.0

frame-relay interface-dlci 103


int s1/0.14 point-to-point

ip add 172.16.14.1 255.255.255.0

frame-relay interface-dlci 104

 

# 가상 인터페이스들도 라우터 네트워크에 추가해줍시다.

router rip

version 2

network 172.16.1.0

network 172.16.12.0
network 172.16.13.0
network 172.16.14.0

no auto-summary

end

wr

R2)

int s1/0

no shut

encapsulation frame-relay

exit

int s1/0.12 point-to-point

ip add 172.16.12.2 255.255.255.0

frame-relay interface-dlci 201

router rip
version 2
network 172.16.2.0
network 172.16.12.0
no auto-summary
end
wr

R3)

int s1/0

no shut

encapsulation frame-relay

exit

int s1/0.13 point-to-point

ip add 172.16.13.2 255.255.255.0

frame-relay interface-dlci 301

router rip
version 2
network 172.16.2.0
network 172.16.13.0
no auto-summary
end
wr

R4)

int s1/0

no shut

encapsulation frame-relay

exit

int s1/0.14 point-to-point

ip add 172.16.14.2 255.255.255.0

frame-relay interface-dlci 401

router rip
version 2
network 172.16.2.0
network 172.16.14.0
no auto-summary
end
wr

R1의 라우터 정보

 

R2의 라우터 정보

 

R2에도 R1에 의해 네트워크 정보를 추가해주지 않았지만

R3, R4 라우팅 정보가 자동으로 추가되며

통신도 정상으로 됨을 확인할 수 있습니다.

 

 

 

NBMA (Non-broadcast Multi Access) 방식

 

NBMA는 브로드캐스트를 기본으로 전송하지 않으며

그러므로 Static으로 네트워크를 수동으로 정해주거나

강제로 Broadcast를 전송하도록 해서 네트워크 정보를 수신해야

통신을 할 수 있습니다.

 

R1)

conf t

int f0/0

ip add 172.16.1.254 255.255.255.0

no sh

 

int s1/0

no sh

encapsulation frame-relay

ip address 172.16.123.1 255.255.255.0

frame-relay map ip 172.16.123.2 102 broadcast

frame-relay map ip 172.16.123.3 103 broadcast

frame-relay map ip 172.16.123.4 104 broadcast

# NBMA는 서브인터페이스를 사용하지 않으며

# 뒤에 broadcast 명령어를 붙이면

# broadcast를 보내도록 설정할 수 있습니다.

 

router rip

version 2

network 172.16.1.0

network 172.16.123.0

no auto-summary

end

wr

R2)

conf t

int f0/0

ip add 172.16.2.254 255.255.255.0

no sh

 

int s1/0

no sh

encapsulation frame-relay

ip address 172.16.123.2 255.255.255.0

frame-relay map ip 172.16.123.1 201 broadcast

 

router rip

version 2

network 172.16.2.0

network 172.16.123.0

no auto-summary

end

wr

 

R3, R4)는 생략

 

R2와 PC2에서 테스트한 결과

 

R2의 라우터 정보에는 R3과 R4의 네트워크 정보가 출력되나

실제로 통신은 R1과만 가능한 것을 확인할 수 있습니다.

 

 

Multipoint

Multipoint는 P2P방식과 NBMA방식을 둘다 사용하는 방식으로

가상회선을 나눠서 두 방식을 나누어서 사용합니다.

R1-R2와 R1-R3은 NMBA 방식

R1-R4는 포인트 투 포인트 방식으로 연결

 

R1)

conf t

int f0/0

ip add 172.16.1.254 255.255.255.0

no sh

 

int s1/0

no sh

encapsulation frame-relay

 

int s1/0.123 multipoint

ip add 172.16.123.1 255.255.255.0

frame-relay map ip 172.16.123.2 102 broadcast

frame-relay map ip 172.16.123.3 103 broadcast

# 멀티포인트를 사용하면 NMBA 방식을 사용하더라도

# 가상회선을 사용해야 합니다.

 

int s1/0.14 point-to-point

ip add 172.16.14.1 255.255.255.0

frame-relay interface-dlci 104

 

router rip

version 2

network 172.16.1.0

network 172.16.123.0

network 172.16.14.0

no auto-summary

end

wr

R2)

conf t

int f0/0

ip add 172.16.2.254 255.255.255.0

no sh

 

int s1/0

no sh

encapsulation frame-relay

 

int s1/0.123 multipoint

ip add 172.16.123.2 255.255.255.0

frame-relay map ip 172.16.123.1 201 broadcast

 

router rip

version 2

network 172.16.2.0

network 172.16.123.0

no auto-summary

end

wr

 

R3는 생략

R4)

conf t

int f0/0

ip add 172.16.4.254 255.255.255.0

no sh

 

int s1/0

no sh

encapsulation frame-relay

 

int s1/0.14 point-to-point

ip add 172.16.14.4 255.255.255.0

frame-relay interface-dlci 401

 

router rip

version 2

network 172.16.4.0

network 172.16.14.0

no auto-summary

end

wr

 

해당 설정은 R2 - R3간에는 통신이 불가능하나

R2 - R4, R3 - R4는 통신이 가능합니다.

 

 

 

 

문제

다음과 같은 네트워크를 전부 Frame-Relay의 Point-to-Point 방식으로 연결해 보세요.

 

 

1-2 / 1-3 / 1-4 / 2-3 / 2-4 / 3-4

모든 경우의 수는 6개가 되므로 6개가 매핑이 되어야 합니다.

 

R1)

conf t

int f0/0

ip add 172.16.1.254 255.255.255.0

no sh

 

int s1/0

no sh

encapsulation frame-relay

 

int s1/0.12 point-to-point

ip add 172.16.12.1 255.255.255.0

frame-relay interface-dlci 102

 

int s1/0.13 point-to-point

ip add 172.16.13.1 255.255.255.0

frame-relay interface-dlci 103

 

int s1/0.14 point-to-point

ip add 172.16.14.1 255.255.255.0

frame-relay interface-dlci 104

 

router rip

version 2

network 172.16.1.0

network 172.16.12.0

network 172.16.13.0

network 172.16.14.0

no auto-summary

end

wr

R2)

conf t

int f0/0

ip add 172.16.2.254 255.255.255.0

no sh

 

int s1/0

no sh

encapsulation frame-relay

 

int s1/0.21 point-to-point

ip add 172.16.12.2 255.255.255.0

frame-relay interface-dlci 201

 

int s1/0.23 point-to-point

ip add 172.16.23.2 255.255.255.0

frame-relay interface-dlci 203

 

int s1/0.24 point-to-point

ip add 172.16.24.2 255.255.255.0

frame-relay interface-dlci 204

 

router rip

version 2

network 172.16.2.0

network 172.16.12.0

network 172.16.23.0

network 172.16.24.0

no auto-summary

end

wr

 

# R3, R4도 마찬가지로 설정해 줍시다.

 

 

 

  • 네이버 블로그 공유
  • 네이버 밴드 공유
  • 페이스북 공유
  • 카카오스토리 공유